CRAN Package Check Results for Package CorrectOverloadedPeaks

Last updated on 2019-05-21 08:48:43 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.16 3.68 104.22 107.90 OK
r-devel-linux-x86_64-debian-gcc 1.2.16 2.64 76.02 78.66 OK
r-devel-linux-x86_64-fedora-clang 1.2.16 93.10 ERROR
r-devel-linux-x86_64-fedora-gcc 1.2.16 125.13 OK
r-devel-windows-ix86+x86_64 1.2.16 8.00 145.00 153.00 OK
r-patched-linux-x86_64 1.2.16 3.27 101.40 104.67 OK
r-release-linux-x86_64 1.2.16 2.93 99.41 102.34 OK
r-release-windows-ix86+x86_64 1.2.16 7.00 122.00 129.00 OK
r-release-osx-x86_64 1.2.16 ERROR
r-oldrel-windows-ix86+x86_64 1.2.16 5.00 95.00 100.00 OK
r-oldrel-osx-x86_64 1.2.16 ERROR

Check Details

Version: 1.2.16
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘xcms’
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 1.2.16
Check: data for non-ASCII characters
Result: WARN
     Error loading dataset 'xcmsRaw_data':
     Error in .requirePackage(package) :
     unable to find required package 'xcms'
    
     The dataset(s) may use package(s) not declared in the DESCRIPTION file.
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64

Version: 1.2.16
Check: examples
Result: ERROR
    Running examples in ‘CorrectOverloadedPeaks-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: FitGaussPeak
    > ### Title: Extrapolate a flat top peak using a Gauss approach.
    > ### Aliases: FitGaussPeak
    >
    > ### ** Examples
    >
    > #load test data
    > data("xcmsRaw_data")
    > str(xcmsRaw_data)
    Loading required package: xcms
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘xcms’
    Error in .requirePackage(package) :
     unable to find required package ‘xcms’
    Calls: str ... .extendsForS3 -> extends -> getClassDef -> .requirePackage
    Execution halted
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 1.2.16
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘CorrectOverloadedPeaks.Rmd’ using rmarkdown
    Quitting from lines 39-40 (CorrectOverloadedPeaks.Rmd)
    Error: processing vignette 'CorrectOverloadedPeaks.Rmd' failed with diagnostics:
    unable to find required package 'xcms'
    --- failed re-building ‘CorrectOverloadedPeaks.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘CorrectOverloadedPeaks.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.2.16
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘CorrectOverloadedPeaks.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 39-40 (CorrectOverloadedPeaks.Rmd)
    Error: processing vignette 'CorrectOverloadedPeaks.Rmd' failed with diagnostics:
    unable to find required package 'xcms'
    --- failed re-building ‘CorrectOverloadedPeaks.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘CorrectOverloadedPeaks.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-osx-x86_64

Version: 1.2.16
Check: data for non-ASCII characters
Result: NOTE
     Error in .requirePackage(package) :
     unable to find required package 'xcms'
     Calls: <Anonymous> ... .extendsForS3 -> extends -> getClassDef -> .requirePackage
     Execution halted
Flavor: r-oldrel-osx-x86_64

Version: 1.2.16
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 39-40 (CorrectOverloadedPeaks.Rmd)
    Error: processing vignette 'CorrectOverloadedPeaks.Rmd' failed with diagnostics:
    unable to find required package 'xcms'
    Execution halted
Flavor: r-oldrel-osx-x86_64